Licencia gratuita y sin registro de Avast

Dejo como autonota la licencia gratuita que me ha otorgado Avast hasta octubre del 2015

C07756868H1200A0916-V2XSTFU5

Para instalarla, pulsar en el icono de Avast, pinchar en el icono de la rueda dentada, buscar el menú “Registro” y buscar “Registro offline” y pinchar el botón “Introducir licencia” y pegamos la que he puesto.

Saludos.

 

 

Copia de seguridad SQL Server 2005 desde consola

He generado este script en consola de ms-dos para generar una copia de seguridad de la base de datos en cuastión. Para ello ejecuto el comando osql que se conecta a la instancia sqlexpress de mi servidor y genera un archivo nombredebasededatos_003042014.bak. Luego paso un comando, forfiles,  que borra ficheros con una antigüedad de más de 7 días para que no me ocupe demasiado.

osql -S SERVIDORSQL\SQLEXPRESS -E -Q "backup database NOMBREBASEDEDATOS to disk = N'nombrebasadedatos_%date:/=_%.bak'"

forfiles /p "C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Backup" /m *.bak /d -7 /c "cmd /c del @file"

Espero que os valga.

Un saludo.

Sacar emails de un texto cualquiera

Dejo esta autonota para no olvidar como sacar mails de un texto cualquiera y que me los deje en un mail por linea para luego poder exportarlo donde quiera.

Me ha surgido el problema ya que quería sacar los mails de los amigos de facebook. Para ello he importado los contactos de facebook a una cuenta de Yahoo. Una vez los tenía en Yahoo los iba a importar y por alguna razón, seguramente una exigencia de facebook a yahoo, no pude exportarlos como archivo csv. Aquí se me ocurrio imprimir todos los contactos en vista clásica y guardar el archivo como PDF. Lo que hace Yahoo es abrir una web con la lista de contactos formateada e imprimirla, pues lo que he hecho es guardar el código fuente de esa web y pasarle el comando para sacar los mails.

El comando en cuestión es este:

juanmi@improvisa:/$ egrep -oi '\b[A-Z0-9._%-]+@[A-Z0-9.-]+\.[A-Z]{2,4}' mails_en_web.html > mails_formateados.txt

Un saludo y espero que os valga 😉

 

GRUB y Mac OSx – Recuperar arranque IATKOS ML en grub

GRUB y Mac OSx – Recuperar arranque IATKOS ML en grub

¡Hola! Me dejo esta autonota para poder arrancar con Grub Mac OSx ya que en mi ordenador portatil con triple boot (Debian 7, Mac OSX y Windows 7) cada vez que actualizo algo se me lía muy gorda y esta última vez ha sido al instalar un nuevo kernel de Debian 7 que actualizó grub.

Mi anterior triple boot tenía que iniciar con Chameleon y ahí elegir si usar Mac o Linux. Luego salía grub  donde podía escoger para iniciar linux o windows 7.

Todo se ha resuleto gracias a la nota de  El Agente 47 donde explica como modificar grub para que nos arranque IatkOs L2.

Hay que buscar en /boot/grub/grub.cfg la linea de Mac y dejarla así:

### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Windows 7 (loader) (on /dev/sda1)" --class windows --class os {
insmod part_msdos
insmod ntfs
set root='(hd0,msdos1)'
search --no-floppy --fs-uuid --set=root E8E40A31E40A0314
chainloader +1
}
menuentry "Mac OS X (32-bit) (on /dev/sda4)" --class osx --class darwin --class os {
insmod hfsplus
set root='(hd0,4)'
multiboot /boot
}

Donde debéis cambiar hd0,4 por vuestro disco, partición

Ahora desde grub podremos elegir los 3 sistemas operativos.

Un saludo y agradecer desde aquí al Agente 47 haberme solcionado el problema 😉

 

Manual Nikon Total Station DTM 350 y Nikon Total Station DTM 330

Os dejo el manual el inglés de la Estación de Nikon para los modelos 330 y 350

Manual Nikon Total Station DTM-350
Manual Nikon Total Station DTM-330

Un saludo.

Voces en español para Asterisk 13, Asterisk 12 y Asterisk 11

Improvisa :: Informática :: Sonidos español para asterisk 11Hola os dejo el link para que podáis descargar las Voces en español para Asterisk 13, Asterisk 12 y Asterisk 11. Fue una locura encontrarlos y al final gracias a una distribución llamada vozbox conseguí sacarlos e incorporarlos a mi asterisk 11, después he comprobado que sigue funcionando en asterisk 12 y asterisk 13.

Los sonidos en español para asterisk 11 asterisk 12 y asterisk 13 están basados en los que en su día publico Alberto Salgredo en voipnovatos, que desde aquí y de nuevo le doy las gracias.

El archivo que os adjunto es el directorio completo /var/lib/asterisk/sounds los dos idiomas unidos, inglés y español.

Una vez que tengáis instalado vuestro asterisk 11, asterisk 12 o asterisk 13 con los sonidos en inglés hacer un mv de los sonidos originales y descargar el archivo que os dejo, tendremos que darle los permisos adecuados, para ello seguir estas instrucciones:

root@asterisk11:~# cd /var/lib/asterisk/
root@asterisk11:/var/lib/asterisk# mv sounds sounds-originales
root@asterisk11:/var/lib/asterisk# wget https://www.improvisa.com/descargas/sonidos_esp_asterisk_11.tar.bz2
root@asterisk11:/var/lib/asterisk# bzip2 -dc sonidos_esp_asterisk_11.tar.bz2 | tar -xv

Esto nos dejará un directorio llamado sounds

root@asterisk11:/var/lib/asterisk# chown asterisk:asterisk sounds -R
root@asterisk11:/var/lib/asterisk# cd sounds
root@asterisk11:/var/lib/asterisk/sounds# chmod 664 * -R
root@asterisk11:/var/lib/asterisk/sounds# find ./ -type d -exec chmod 775 {} \;

Ya los tendremos en español e inglés

Os dejo el link en mis servidores, un saludo.

https://www.improvisa.com/descargas/sonidos_esp_asterisk_11.tar.bz2

Hostname fijo en vps 1and1

Después de comprar mi VPS en 1and1 o 1&1 me he dado cuenta que después de cambiar el nombre del hostname a mi Debian cada vez que lo reinicio vuelve a quedarse con el mismo número ilegible que le da el panel Virtuozzo.

Para cambiarlo y que se quede fijo debemos hacer lo siguiente:

root@s1690234425:~# vi /etc/hostname

pondremos el nombre que queramos.

root@s1690234425:~# /etc/init.d/hostname.sh

Una vez hecho debemos decirle que el archivo no pueda cambiarse:

root@s1690234425:~# chattr +i /etc/hostname

Con esto después de reiniciar tendremos nuestro nombre de host como queremos.

Saludos.

OpenWRT como Repetidor y Puente

Dejo esta configuración ya que me ha costado encontrar la solución al modo wifi que quería en mi OpenWRT. Necesitaba poner mi Router TP-Link  TL-WR842ND con OpenWRT en modo repetidor wifi. El modo es algo extraño ya que debe tener una interfaz wifi que se conecta como cliente a un essid existente y por otra parte emitir otro nuevo essid y deben estar sin enrutar, es decir, las dos redes y todos los equipos conectados deben hacerlo a la misma red.

Asumo que ya tenemos flasheado el Router con la última versión de OpwnWRT.

Para ello necesitaremos instalar el paquete relayd, para ello pondremos esto en nuestro SSH:

opkg update
opkg install relayd
/etc/init.d/relayd enable

La configuración de la wifi será la siguiente (/etc/config/wireless):

config wifi-device ‘radio0’
option channel ‘1’ #Debe ser el mismo que el canal que tiene el essid al que me voy a conectar
option disabled ‘0’

config wifi-iface
option ssid ‘essid_al_que_conecto’
option encryption ‘psk2’ 
option device ‘radio0’
option mode ‘sta’
option network ‘wwan’
option key ‘password’

config wifi-iface
option device ‘radio0’
option mode ‘ap’
option ssid ‘essid_nuevo’
option encryption ‘psk2’
option key ‘password’
option network ‘lan’

Ojo con la primera parte de este archivo, cambiará según las opciones que tengamos.

La configuración de red será esta (etc/config/network):

config interface ‘loopback’
option ifname ‘lo’
option proto ‘static’
option ipaddr ‘127.0.0.1’
option netmask ‘255.0.0.0’

config interface ‘lan’
option ifname ‘eth0’
option type ‘bridge’
option proto ‘static’
option ipaddr ‘10.0.1.240’
option netmask ‘255.0.0.0’
option gateway ‘10.0.0.1’
option dns ‘8.8.8.8’

config interface ‘wwan’
option proto ‘dhcp’ #Esta es la ip importante, es nuestra red. El resto como el ejemplo. Si queremos podemos poner esta estática.

config ‘interface’ ‘stabridge’
option ‘proto’ ‘relay’
option ‘network’ ‘lan wwan’
option ipaddr ‘10.0.0.240’

Debemos deshabilitar DHCP ya que lo dará otro router de la red. Con este modo se pasa todo el tráfico al siguietne AP (/etc/config/dhcp).

config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h
option ignore 1

config dhcp wan
option interface wan
option ignore 1

Lo único que nos queda es deshabilitar el firewall ya que no nos hará falta.

/etc/init.d/firewall stop

/etc/init.d/firewall disable

Con esto ya tendremos nuestro OpenWRT en modo repetidor.

Saludos.

Capturar fireware desde consola con Debian

Dejo esta autonota porque cada vez que tengo que capturar con mi cámara MiniDV lo último grabado, nunca me acuerdo de como tengo que hacerlo y pierdo 10 minutos en encontrarlo:

Para capturar utilizo el comando dvgrab, para ello sólo necesitaremos instalar el paquete con:

root@improvisa:/# apt-get install dvgrab

Ahora una vez pinchada la cámara al puerto fireware y rebobinada hasta donde queremos comenzar sólo tenemos que ejecutar este comando para que lance una captura hasta que llegue la final de la cinta o lo cancelemos.

 

root@improvisa:/# dvgrab -f avi -s 0 /carpeta_de_destino/archivo.avi

El comando le dice a dvgrab que capture en el contenedor avi sin pérdida de calidad y lo deje todo en un fichero, no haga autosplit.

En mi caso que para lo que lo necesito es para capturar funciones enteras de una compañía de clown, www.colectivoclown.com, necesito eso, no perder datos y todo de principio a fin en un solo fichero.

Dvgrab tiene muchísimas más opciones, podéis visitar su página man dvgrab y verlas todas.

Un saludo.

 

Reparar MySQL

Después de un error en mi base de datos he tenido que reparar la base de datos mysql, dejo aquí los comando que he tenido que utilizar como autonota porque seguramente me ocurra alguna que otra vez. Si alguien necesita lo mismo pues también lo tiene 😉

Existen dos caminos a elegir, mysqlcheck y myisamchk, la gran diferencia es que uno no necesita que paremos la base de datos y el otro si, también que uno trabaja directamente sobre los archivos del disco duro y el otro sobre la base de datos montada.

Con mysqlcheck NO debemos parar la base de datos y los comandos son estos, aunque no veáis mysqlcheck, estos comandos son atajos a ese comando:

root@improvisa:/# mysqlrepair –all-databases -u root -p
root@improvisa:/# mysqloptimize –all-databases -u root -p

Con myisamchk debemos para la base de datos, ir al directorio que contiene nuestras bases de datos y desde allí lanzar el comando y una vez acabado rearmar la base de datos

root@improvisa:/# /etc/init.d/mysql stop
Stopping MySQL database server: mysqld.

root@improvisa:/# cd /var/lib/mysql/
root@improvisa:/var/lib/mysql/# find ./ -type f -name “*.MYI” -exec myisamchk -r {} \;

root@improvisa:/# /etc/init.d/mysql start
Starting MySQL database server: mysqld.
Checking for corrupt, not cleanly closed and upgrade needing tables..

Un saludo